using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/path-one\/[0-9]+\/status";
string input = @"/path-one/12/status
/path-one/18/status
/path-one/103/status
/path-one/9821/status";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}