$re = '/\/path-one\/[0-9]+\/status/m';
$str = '/path-one/12/status
/path-one/18/status
/path-one/103/status
/path-one/9821/status';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);