// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/path-one\/[0-9]+\/status").unwrap();
let string = "/path-one/12/status
/path-one/18/status
/path-one/103/status
/path-one/9821/status";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}