const regex = /\/path-one\/[0-9]+\/status/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/path-one\\\/[0-9]+\\\/status', 'gm')
const str = `/path-one/12/status
/path-one/18/status
/path-one/103/status
/path-one/9821/status`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}