package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/path-one\/[0-9]+\/status`)
var str = `/path-one/12/status
/path-one/18/status
/path-one/103/status
/path-one/9821/status`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}