#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)^.{0,1000}DELETE ME[^\r\n]*\R"
Local $sString = "unnecessary stuff" & @CRLF & _
"unnecessary stuff" & @CRLF & _
"DELETE ME and some more stuff" & @CRLF & _
"This line should be the beginning" & @CRLF & _
"the rest."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")