// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?is)^.{0,1000}DELETE ME[^\r\n]*\R").unwrap();
let string = "unnecessary stuff
unnecessary stuff
DELETE ME and some more stuff
This line should be the beginning
the rest.";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}