const regex = /^.{0,1000}DELETE ME[^\r\n]*\R/is;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.{0,1000}DELETE ME[^\\r\\n]*\\R', 'is')
const str = `unnecessary stuff
unnecessary stuff
DELETE ME and some more stuff
This line should be the beginning
the rest.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}