$re = '/^.{0,1000}DELETE ME[^\r\n]*\R/is';
$str = 'unnecessary stuff
unnecessary stuff
DELETE ME and some more stuff
This line should be the beginning
the rest.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);