package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)^.{0,1000}DELETE ME[^\r\n]*\R`)
var str = `unnecessary stuff
unnecessary stuff
DELETE ME and some more stuff
This line should be the beginning
the rest.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}