const regex = /([a-z])\s/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-z])\\s', 'g')
const str = `set , 1
note , 1
hello , 1`;
const subst = `$1' `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);