# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/C([A-Z].+)T//;t' <<< " ABCDEFGHIJKLMNOPQRSTUVWXYZ CERTIFICATION
0123456789
"