use strict;
my $str = ' ABCDEFGHIJKLMNOPQRSTUVWXYZ CERTIFICATION
0123456789
';
my $regex = qr/C([A-Z].+)T/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";