#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/\*([\S\s]+?)\*\/"
Local $sString = "/* Comment type1 */" & @CRLF & _
"" & @CRLF & _
"foo" & @CRLF & _
"/* " & @CRLF & _
"" & @CRLF & _
" * JD-Core Version: 0.7.0.1" & @CRLF & _
"" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"// hello"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")