$re = '/\/\*([\S\s]+?)\*\//';
$str = '/* Comment type1 */
foo
/*
* JD-Core Version: 0.7.0.1
*/
// hello';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);