import Foundation
let pattern = #"\/\*([\S\s]+?)\*\/"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
/* Comment type1 */
foo
/*
* JD-Core Version: 0.7.0.1
*/
// hello
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}