import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\*([\\S\\s]+?)\\*\\/";
final String string = "/* Comment type1 */\n\n"
+ "foo\n"
+ "/* \n\n"
+ " * JD-Core Version: 0.7.0.1\n\n"
+ "*/\n\n"
+ "// hello";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}