package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/\*([\S\s]+?)\*\/`)
var str = `/* Comment type1 */
foo
/*
* JD-Core Version: 0.7.0.1
*/
// hello`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}