use strict;
my $str = '<td class="spLightGray lrBorder"><span class="textBold">Completed</span></td>
<td>2/3/22, 12:30:00 PM
</td>';
my $regex = qr/>Completed</span></td>
<td>(-*?)/sp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}