re = />Completed<\/span><\/td>
<td>(-*?)/
str = '<td class="spLightGray lrBorder"><span class="textBold">Completed</span></td>
<td>2/3/22, 12:30:00 PM
</td>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end