$re = '/>Completed</span></td>
<td>(-*?)/s';
$str = '<td class="spLightGray lrBorder"><span class="textBold">Completed</span></td>
<td>2/3/22, 12:30:00 PM
</td>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);