import Foundation
let pattern = #"""
>Completed</span></td>
<td>(-*?)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<td class="spLightGray lrBorder"><span class="textBold">Completed</span></td>
<td>2/3/22, 12:30:00 PM
</td>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}