#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^ *if \(.+\).*({)"
Local $sString = "// Don't match these" & @CRLF & _
"if (something == something) a;" & @CRLF & _
"" & @CRLF & _
" if (another == 3438) a;" & @CRLF & _
"" & @CRLF & _
" if (asdfsad == 3425435) a;" & @CRLF & _
"" & @CRLF & _
" if (asdsda == 'a') SomeFunction(); // And a comment" & @CRLF & _
"" & @CRLF & _
" if () asdf sdf sd sdfsdf; // Another comment" & @CRLF & _
"" & @CRLF & _
"don't match this line if (asdfsad == 3425435) a; // Another comment" & @CRLF & _
"" & @CRLF & _
"// Match these" & @CRLF & _
"if (something) { // A comment" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
" if (assda) { // Another comment" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")