package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^ *if \(.+\).*({)`)
var str = `// Don't match these
if (something == something) a;
if (another == 3438) a;
if (asdfsad == 3425435) a;
if (asdsda == 'a') SomeFunction(); // And a comment
if () asdf sdf sd sdfsdf; // Another comment
don't match this line if (asdfsad == 3425435) a; // Another comment
// Match these
if (something) { // A comment
}
if (assda) { // Another comment
}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}