using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ *if \(.+\).*({)";
string input = @"// Don't match these
if (something == something) a;
if (another == 3438) a;
if (asdfsad == 3425435) a;
if (asdsda == 'a') SomeFunction(); // And a comment
if () asdf sdf sd sdfsdf; // Another comment
don't match this line if (asdfsad == 3425435) a; // Another comment
// Match these
if (something) { // A comment
}
if (assda) { // Another comment
}
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}