import Foundation
let pattern = #"^ *if \(.+\).*({)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
// Don't match these
if (something == something) a;
if (another == 3438) a;
if (asdfsad == 3425435) a;
if (asdsda == 'a') SomeFunction(); // And a comment
if () asdf sdf sd sdfsdf; // Another comment
don't match this line if (asdfsad == 3425435) a; // Another comment
// Match these
if (something) { // A comment
}
if (assda) { // Another comment
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)