#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[([\w.]*?)\|(.*?)\]"
Local $sString = "gewgweg ewwegoih #ihogewig #CorporateRaid [durov|Дуров]" & @CRLF & _
"Wsasd asdff [somebody|Кто-то] #HIii" & @CRLF & _
" [ewgwe?!!!**|gewg] se" & @CRLF & _
""
Local $sSubst = "$2 (vk.com/$1)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)