const regex = /\[([\w.]*?)\|(.*?)\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[([\\w.]*?)\\|(.*?)\\]', 'g')
const str = `gewgweg ewwegoih #ihogewig #CorporateRaid [durov|Дуров]
Wsasd asdff [somebody|Кто-то] #HIii
[ewgwe?!!!**|gewg] se
`;
const subst = `$2 (vk.com/$1)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);