import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[([\\w.]*?)\\|(.*?)\\]";
final String string = "gewgweg ewwegoih #ihogewig #CorporateRaid [durov|Дуров]\n"
+ "Wsasd asdff [somebody|Кто-то] #HIii\n"
+ " [ewgwe?!!!**|gewg] se\n";
final String subst = "$2 (vk.com/$1)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}