use strict;
my $str = 'gewgweg ewwegoih #ihogewig #CorporateRaid [durov|Дуров]
Wsasd asdff [somebody|Кто-то] #HIii
[ewgwe?!!!**|gewg] se
';
my $regex = qr/\[([\w.]*?)\|(.*?)\]/p;
my $subst = '$2 (vk.com/$1)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";