import Foundation
let pattern = #"\[([\w.]*?)\|(.*?)\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
gewgweg ewwegoih #ihogewig #CorporateRaid [durov|Дуров]
Wsasd asdff [somebody|Кто-то] #HIii
[ewgwe?!!!**|gewg] se
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2 (vk.com/$1)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)