using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[([\w.]*?)\|(.*?)\]";
string substitution = @"$2 (vk.com/$1)";
string input = @"gewgweg ewwegoih #ihogewig #CorporateRaid [durov|Дуров]
Wsasd asdff [somebody|Кто-то] #HIii
[ewgwe?!!!**|gewg] se
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}