# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\w{2}-\w{2})\/questions\/(\w+)$/\/questions.aspx?lang=\1&tab=\2/gm;t' <<< "en-us/questions/ask
en-us/questions/newest/15
en-us/questions/12/just-a-text-to-be-ignored
en-us/questions/newest"