package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w{2}-\w{2})/questions/(\w+)$`)
var str = `en-us/questions/ask
en-us/questions/newest/15
en-us/questions/12/just-a-text-to-be-ignored
en-us/questions/newest`
var substitution = "/questions.aspx?lang=\1&tab=\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}