use strict;
my $str = 'en-us/questions/ask
en-us/questions/newest/15
en-us/questions/12/just-a-text-to-be-ignored
en-us/questions/newest';
my $regex = qr/^(\w{2}-\w{2})/questions/(\w+)$/mp;
my $subst = '/questions.aspx?lang=\\1&tab=\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";