import Foundation
let pattern = #"^(\w{2}-\w{2})/questions/(\w+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
en-us/questions/ask
en-us/questions/newest/15
en-us/questions/12/just-a-text-to-be-ignored
en-us/questions/newest
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/questions.aspx?lang=\1&tab=\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)