import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w{2}-\\w{2})/questions/(\\w+)$";
final String string = "en-us/questions/ask\n"
+ "en-us/questions/newest/15\n"
+ "en-us/questions/12/just-a-text-to-be-ignored\n"
+ "en-us/questions/newest";
final String subst = "/questions.aspx?lang=\\1&tab=\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}