#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xs)int\s+.*? (" & @CRLF & _
" \{ # Match opening brace" & @CRLF & _
" (?: # Start non-capturing group" & @CRLF & _
" [^{}]++ # Match non-brace chars without backtracking" & @CRLF & _
" | # OR" & @CRLF & _
" (?-1) # Recursively match the entire expression" & @CRLF & _
" )* # Match 0 or more times" & @CRLF & _
" \}" & @CRLF & _
")"
Local $sString = "int max(int x, int y)" & @CRLF & _
"{" & @CRLF & _
" if (x > y)" & @CRLF & _
" {" & @CRLF & _
" return x;" & @CRLF & _
" }" & @CRLF & _
" else" & @CRLF & _
" {" & @CRLF & _
" return y;" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")