import re
regex = re.compile(r"""
int\s+.*? (
\{ # Match opening brace
(?: # Start non-capturing group
[^{}]++ # Match non-brace chars without backtracking
| # OR
(?-1) # Recursively match the entire expression
)* # Match 0 or more times
\}
)
""", flags=re.VERBOSE | re.DOTALL)
test_str = ("int max(int x, int y)\n"
"{\n"
" if (x > y)\n"
" {\n"
" return x;\n"
" }\n"
" else\n"
" {\n"
" return y;\n"
" }\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")