re = /int\s+.*? (
\{ # Match opening brace
(?: # Start non-capturing group
[^{}]++ # Match non-brace chars without backtracking
| # OR
(?-1) # Recursively match the entire expression
)* # Match 0 or more times
\}
)/x
str = 'int max(int x, int y)
{
if (x > y)
{
return x;
}
else
{
return y;
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end