using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"int\s+.*? (
\{ # Match opening brace
(?: # Start non-capturing group
[^{}]++ # Match non-brace chars without backtracking
| # OR
(?-1) # Recursively match the entire expression
)* # Match 0 or more times
\}
)";
string input = @"int max(int x, int y)
{
if (x > y)
{
return x;
}
else
{
return y;
}
}";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}