package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)int\s+.*? (
\{ # Match opening brace
(?: # Start non-capturing group
[^{}]++ # Match non-brace chars without backtracking
| # OR
(?-1) # Recursively match the entire expression
)* # Match 0 or more times
\}
)`)
var str = `int max(int x, int y)
{
if (x > y)
{
return x;
}
else
{
return y;
}
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}