import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "int\\s+.*? (\n"
+ " \\{ # Match opening brace\n"
+ " (?: # Start non-capturing group\n"
+ " [^\\{\\}]++ # Match non-brace chars without backtracking\n"
+ " | # OR\n"
+ " (?-1) # Recursively match the entire expression\n"
+ " )* # Match 0 or more times\n"
+ " \\}\n"
+ ")";
final String string = "int max(int x, int y)\n"
+ "{\n"
+ " if (x > y)\n"
+ " {\n"
+ " return x;\n"
+ " }\n"
+ " else\n"
+ " {\n"
+ " return y;\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}