#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*\/([^\/]+)\/([^\/]+)\/([^\/]+)\?ds=.*$"
Local $sString = "file://server-name-01/e$/(any file or subfolder)?ds=test_01" & @CRLF & _
"file://server-name-02/e$/(any file or subfolder)?ds=test_01" & @CRLF & _
"file://server-name-03/e$/(any file or subfolder)?ds=test_01 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")