$re = '/^.*\/([^\/]+)\/([^\/]+)\/([^\/]+)\?ds=.*$/m';
$str = 'file://server-name-01/e$/(any file or subfolder)?ds=test_01
file://server-name-02/e$/(any file or subfolder)?ds=test_01
file://server-name-03/e$/(any file or subfolder)?ds=test_01 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);