#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\b.+\b)\1"
Local $sString = "are blue and then a and then very bright"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)