$re = '/(\b.+\b)\1/';
$str = 'are blue and then a and then very bright';
$subst = "\1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;