re = /(\b.+\b)\1/
str = 'are blue and then a and then very bright'
subst = '\\1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result