use strict;
my $str = 'are blue and then a and then very bright';
my $regex = qr/(\b.+\b)\1/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";