using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b.+\b)\1";
string substitution = @"\1";
string input = @"are blue and then a and then very bright";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}